Reply: Joomla 3.6

NOTE: You are posting the message as a 'Guest', you can not edit the message or delete it
Please Log in or Register to skip this step.
X

Topic History of: Joomla 3.6

Max. showing the last 6 posts - (Last post first)

  • Ryan
5 years 4 months ago
Joomla 3.6

Thanks for the workaround! That does indeed seem to work.

  • admin
5 years 4 months ago
Joomla 3.6

Hmm. I spoke too soon..

It appears that Joomla have changed the timing of when the JTableUser class is loaded. This means that I am unable to override it using my system plugin..

Unless I can find a better solution, then it may be necessary to go back to hacking the core file..

If anybody wants to do this then you need to comment out the following in the file /libraries/joomla/table/user.php

/*		// Check for existing email
		$query->clear()
			->select($this->_db->quoteName('id'))
			->from($this->_db->quoteName('#__users'))
			->where($this->_db->quoteName('email') . ' = ' . $this->_db->quote($this->email))
			->where($this->_db->quoteName('id') . ' != ' . (int) $this->id);
		$this->_db->setQuery($query);
		$xid = (int) $this->_db->loadResult();

		if ($xid && $xid != (int) $this->id)
		{
			$this->setError(JText::_('JLIB_DATABASE_ERROR_EMAIL_INUSE'));

			return false;
		}
*/

Unfortunately you would need to redo this every time Joomla is updated

  • Ryan
5 years 4 months ago
Joomla 3.6

Great to hear! I'll keep an eye out. Thanks!

  • admin
5 years 4 months ago
Joomla 3.6

Hi Ryan,

Yes, the new release will be out by the weekend. I was taken a bit by surprise with the release of 3.6, but I will be working on it tomorrow

  • Ryan
5 years 4 months ago
Joomla 3.6

With the release of Joomla 3.6, version 1.0.5 of the plugin no longer works. Is there an upgrade planned? Any timeline yet? This is the only component holding back our upgrade of Joomla.

Thanks!

-Ryan

Time to create page: 0.128 seconds
Powered by Kunena Forum